CVE-2024-53299

Medium

Description

The request handling in the core in Apache Wicket 7.0.0 on any platform allows an attacker to create a DOS via multiple requests to server resources. Users are recommended to upgrade to versions 9.19.0 or 10.3.0, which fixes this issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Wicket
PublishedJan 23, 2025
First seenJan 23, 2025

How to fix

Update
  • apache wicket9.19.0, 10.3.0 or later
  • org.apache.wicket:wicket-core8.17.0, 10.3.0, 9.19.0 or later

Affected products

ProductAffected versionsFixed in
apache wicket7.0.0 ≤ v ≤ 7.18.0, 8.0.0 ≤ v ≤ 8.16.0, 9.0.0 ≤ v < 9.19.0, 10.0.0 ≤ v < 10.3.09.19.0, 10.3.0
org.apache.wicket:wicket-coreMaven7.0.0 ≤ v < 8.17.0, 10.0.0 ≤ v < 10.3.0, 9.0.0-M1 ≤ v < 9.19.08.17.0, 10.3.0, 9.19.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-53299 · Apache Wicket · Dark Radar