CVE-2024-53948

Medium

Description

Generation of Error Message Containing analytics metadata Information in Apache Superset. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

SeverityMedium
CVSS5.3
Exploit probability59. percentile0.9%
ProductApache Superset
PublishedDec 9, 2024
First seenDec 9, 2024
Weakness typeCWE-209CWE-209

How to fix

Update
  • apache superset4.1.0 or later
  • apache-superset4.1.0 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 4.1.04.1.0
apache-supersetPyPIv < 4.1.04.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.