CVE-2024-53949
Medium
Description
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Superset
PublishedDec 9, 2024
First seenDec 9, 2024
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- apache superset4.1.0 or later
- apache-superset4.1.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | 2.0.0 ≤ v < 4.1.0 | 4.1.0 |
| apache-supersetPyPI | 2.0.0 ≤ v < 4.1.0 | 4.1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.