CVE-2024-53983

Medium

Description

The Backstage Scaffolder plugin Houses types and utilities for building scaffolder-related modules. A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin. The issue has been resolved in versions `v0.4.12`, `v0.5.1` and `v0.6.1` of the `@backstage/plugin-scaffolder-node` package. Users are encouraged to upgrade to this version to mitigate the vulnerability. Users are advised to upgrade. Users unable to upgrade may ensure that templates do not change git config.

SeverityMedium
CVSS5.4
Exploit probability—
Product@backstage/plugin-scaffolder-node
PublishedNov 29, 2024
First seenNov 29, 2024

How to fix

Update
  • @backstage/plugin-scaffolder-node0.4.12, 0.5.1, 0.6.1 or later

Affected products

ProductAffected versionsFixed in
@backstage/plugin-scaffolder-nodenpmv < 0.4.12, 0.5.0 ≤ v < 0.5.1, 0.6.0 ≤ v < 0.6.10.4.12, 0.5.1, 0.6.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.