CVE-2024-54016
Medium
Description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): through <=2.2.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
SeverityMedium
CVSS4.3
Exploit probability—
Product
Apache Seata
PublishedMar 20, 2025
First seenMar 20, 2025
Weakness typeCWE-409CWE-409
How to fix
Update
- apache seata2.3.0 or later
- org.apache.seata:seata-parent2.3.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache seata | 2.0.0 ≤ v < 2.3.0 | 2.3.0 |
| org.apache.seata:seata-parentMaven | 2.0.0 ≤ v < 2.3.0 | 2.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.