CVE-2024-54152

Critical

Description

Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to version 1.4.3, an attacker can write a malicious expression that escapes the sandbox to execute arbitrary code on the system. With a more complex (undisclosed) payload, one can get full access to Arbitrary code execution on the system. The problem has been patched in version 1.4.3 of Angular Expressions. Two possible workarounds are available. One may either disable access to `__proto__` globally or make sure that one uses the function with just one argument.

SeverityCritical
CVSS9.3
Exploit probability—
ProductAngular-expressions
PublishedDec 10, 2024
First seenDec 10, 2024

How to fix

Update
  • angular-expressions1.4.3 or later

Affected products

ProductAffected versionsFixed in
angular-expressionsnpmv < 1.4.31.4.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-54152 · Angular-expressions · Dark Radar