CVE-2024-5436

Critical

Description

Type confusion in Snapchat LensCore could lead to denial of service or arbitrary code execution prior to version 12.88. We recommend upgrading to version 12.88 or above.

SeverityCritical
CVSS9.8
Exploit probability—
ProductSnapchat Lenscore
PublishedMay 31, 2024
First seenMay 31, 2024
Weakness typeCWE-704CWE-704

How to fix

Update
  • snap snapchat_lenscore12.88 or later

Affected products

ProductAffected versionsFixed in
snap snapchat_lenscorev < 12.8812.88

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.