CVE-2024-54677
Description
Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.
How to fix
- apache tomcat9.0.98, 10.1.34, 11.0.2 or later
- org.apache.tomcat:tomcat11.0.2, 10.1.34, 9.0.98 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.0 ≤ v < 9.0.98, 10.1.0 ≤ v < 10.1.34, 11.0.0 ≤ v < 11.0.2 | 9.0.98, 10.1.34, 11.0.2 |
| netapp bootstrap_os | No range specified | — |
| org.apache.tomcat:tomcatMaven | 11.0.0-M1 ≤ v < 11.0.2, 10.1.0-M1 ≤ v < 10.1.34, 9.0.0.M1 ≤ v < 9.0.98 | 11.0.2, 10.1.34, 9.0.98 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.