CVE-2024-5566
Medium
Description
An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.
SeverityMedium
CVSS5.8
Exploit probability—
ProductGithub Enterprise Server
PublishedJul 16, 2024
First seenJul 16, 2024
Weakness typeCWE-269Improper privilege management
How to fix
Update
- github enterprise_server3.9.17, 3.10.14, 3.11.12, 3.12.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | 3.9.0 ≤ v < 3.9.17, 3.10.0 ≤ v < 3.10.14, 3.11.0 ≤ v < 3.11.12, 3.12.0 ≤ v < 3.12.6, 3.13.0 | 3.9.17, 3.10.14, 3.11.12, 3.12.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.