CVE-2024-55662
Description
XWiki Platform is a generic wiki platform. Starting in version 3.3-milestone-1 and prior to versions 15.10.9 and 16.3.0, on instances where `Extension Repository Application` is installed, any user can execute any code requiring `programming` rights on the server. This vulnerability has been fixed in XWiki 15.10.9 and 16.3.0. Since `Extension Repository Application` is not mandatory, it can be safely disabled on instances that do not use it as a workaround. It is also possible to manually apply the patches from commit 8659f17d500522bf33595e402391592a35a162e8 to the page `ExtensionCode.ExtensionSheet` and to the page `ExtensionCode.ExtensionAuthorsDisplayer`.
How to fix
- xwiki xwiki15.10.9, 16.3.0 or later
- org.xwiki.platform:xwiki-platform-repository-server-ui15.10.9, 16.3.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki | 3.3 ≤ v < 15.10.9, 16.0.0 ≤ v < 16.3.0 | 15.10.9, 16.3.0 |
| org.xwiki.platform:xwiki-platform-repository-server-uiMaven | 3.3-milestone-1 ≤ v < 15.10.9, 16.0.0-rc-1 ≤ v < 16.3.0 | 15.10.9, 16.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.