CVE-2024-55879
Description
XWiki Platform is a generic wiki platform. Starting in version 2.3 and prior to versions 15.10.9, 16.3.0, any user with script rights can perform arbitrary remote code execution by adding instances of `XWiki.ConfigurableClass` to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 15.10.9 and 16.3.0. No known workarounds are available except upgrading.
How to fix
- xwiki xwiki15.10.9, 16.3.0 or later
- org.xwiki.platform:xwiki-platform-administration-ui15.10.9, 16.3.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki | 2.3 ≤ v < 15.10.9, 16.0.0 ≤ v < 16.3.0 | 15.10.9, 16.3.0 |
| org.xwiki.platform:xwiki-platform-administration-uiMaven | 2.3 ≤ v < 15.10.9, 16.0.0-rc-1 ≤ v < 16.3.0 | 15.10.9, 16.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.