CVE-2024-55890

Medium

Description

D-Tale is a visualizer for pandas data structures. Prior to version 3.16.1, users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. Users should upgrade to version 3.16.1 where the `update-settings` endpoint blocks the ability for users to update the `enable_custom_filters` flag. The only workaround for versions earlier than 3.16.1 is to only host D-Tale to trusted users.

SeverityMedium
CVSS6.9
Exploit probability—
ProductDtale
PublishedDec 13, 2024
First seenDec 13, 2024

How to fix

Update
  • dtale3.16.1 or later

Affected products

ProductAffected versionsFixed in
dtalePyPIv < 3.16.13.16.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.