CVE-2024-55893

Medium

Description

TYPO3 is a free and open source Content Management Framework. A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method. Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following conditions: The user opens a malicious link, such as one sent via email. The user visits a compromised or manipulated website while the following settings are misconfigured: 1. `security.backend.enforceReferrer` feature is disabled, 2. `BE/cookieSameSite` configuration is set to lax or none. The vulnerability in the affected downstream component “Log Module” allows attackers to remove log entries. Users are advised to update to TYPO3 versions 11.5.42 ELTS, 12.4.25 LTS, 13.4.3 LTS which fix the problem described. There are no known workarounds for this vulnerability.

SeverityMedium
CVSS4.3
Exploit probability—
ProductTypo3
PublishedJan 14, 2025
First seenJan 14, 2025

How to fix

Update
  • typo3 typo310.4.48, 11.5.42, 12.4.25, 13.4.3 or later
  • typo3/cms-belog10.4.48, 11.5.42, 12.4.25, 13.4.3 or later

Affected products

ProductAffected versionsFixed in
typo3 typo310.0.0 ≤ v < 10.4.48, 11.0.0 ≤ v < 11.5.42, 12.0.0 ≤ v < 12.4.25, 13.0.0 ≤ v < 13.4.310.4.48, 11.5.42, 12.4.25, 13.4.3
typo3/cms-belogPackagist10.0.0 ≤ v < 10.4.48, 11.0.0 ≤ v < 11.5.42, 12.0.0 ≤ v < 12.4.25, 13.0.0 ≤ v < 13.4.310.4.48, 11.5.42, 12.4.25, 13.4.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.