CVE-2024-56145
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: Jun 23, 2025- craftcms craft_cms3.9.14, 4.13.2, 5.5.2 or later
- craftcms/cms5.5.2, 4.13.2, 3.9.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 3.0.0 ≤ v < 3.9.14, 4.0.0 ≤ v < 4.13.2, 5.0.0 ≤ v < 5.5.2 | 3.9.14, 4.13.2, 5.5.2 |
| craftcms/cmsPackagist | 5.0.0-RC1 ≤ v < 5.5.2, 4.0.0-RC1 ≤ v < 4.13.2, 3.0.0 ≤ v < 3.9.14 | 5.5.2, 4.13.2, 3.9.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.