CVE-2024-56332
Description
Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.
How to fix
- vercel next.js13.5.8, 14.2.21, 15.1.2 or later
- next13.5.8, 14.2.21, 15.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 13.0.0 ≤ v < 13.5.8, 14.0.0 ≤ v < 14.2.21, 15.0.0 ≤ v < 15.1.2 | 13.5.8, 14.2.21, 15.1.2 |
| nextnpm | 13.0.0 ≤ v < 13.5.8, 14.0.0 ≤ v < 14.2.21, 15.0.0 ≤ v < 15.1.2 | 13.5.8, 14.2.21, 15.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.