CVE-2024-56507

Medium

Description

LinkAce is a self-hosted archive to collect links of your favorite websites. Prior to 1.15.6, a reflected cross-site scripting (XSS) vulnerability exists in the LinkAce. This issue occurs in the "URL" field of the "Edit Link" module, where user input is not properly sanitized or encoded before being reflected in the HTML response. This allows attackers to inject and execute arbitrary JavaScript in the context of the victim’s browser, leading to potential session hijacking, data theft, and unauthorized actions. This vulnerability is fixed in 1.15.6.

SeverityMedium
CVSS4.6
Exploit probability—
ProductLinkace
PublishedDec 27, 2024
First seenDec 27, 2024

How to fix

Update
  • linkace linkace1.15.6 or later

Affected products

ProductAffected versionsFixed in
linkace linkacev < 1.15.61.15.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.