CVE-2024-56731

Critical

Description

Gogs is an open source self-hosted Git service. Prior to version 0.13.3, it's still possible to delete files under the .git directory and achieve remote command execution due to an insufficient patch for CVE-2024-39931. Unprivileged user accounts can execute arbitrary commands on the Gogs instance with the privileges of the account specified by RUN_USER in the configuration. Allowing attackers to access and alter any users' code hosted on the same instance. This issue has been patched in version 0.13.3.

SeverityCritical
CVSS10.0
Exploit probability—
ProductGogs
PublishedJun 24, 2025
First seenJun 24, 2025
Weakness typeCWE-552CWE-552

How to fix

Update
  • gogs gogs0.13.3 or later
  • gogs.io/gogs0.13.3 or later

Affected products

ProductAffected versionsFixed in
gogs gogsv < 0.13.30.13.3
gogs.io/gogsGov < 0.13.30.13.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.