CVE-2024-56915

Medium

Description

Netbox Community v4.1.7 and fixed in v.4.2.2 is vulnerable to Cross Site Scripting (XSS) via the RSS feed widget.

SeverityMedium
CVSS6.5
Exploit probability—
ProductNetbox
PublishedJun 26, 2025
First seenJun 26, 2025

How to fix

Update
  • netbox netbox4.2.2 or later

Affected products

ProductAffected versionsFixed in
netbox netbox4.1.7 ≤ v < 4.2.24.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.