CVE-2024-5795

High

Description

A Denial of Service vulnerability was identified in GitHub Enterprise Server that allowed an attacker to cause unbounded resource exhaustion by sending a large payload to the Git server. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

SeverityHigh
CVSS7.7
Exploit probability—
ProductGithub Enterprise Server
PublishedJul 16, 2024
First seenJul 16, 2024

How to fix

Update
  • github enterprise_server3.9.17, 3.10.14, 3.11.12, 3.12.6 or later

Affected products

ProductAffected versionsFixed in
github enterprise_server3.9.0 ≤ v < 3.9.17, 3.10.0 ≤ v < 3.10.14, 3.11.0 ≤ v < 3.11.12, 3.12.0 ≤ v < 3.12.6, 3.13.03.9.17, 3.10.14, 3.11.12, 3.12.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.