CVE-2024-5815
Description
A Cross-Site Request Forgery vulnerability in GitHub Enterprise Server allowed write operations on a victim-owned repository by exploiting incorrect request types. A mitigating factor is that the attacker would have to be a trusted GitHub Enterprise Server user, and the victim would have to visit a tag in the attacker's fork of their own repository. vulnerability affected all versions of GitHub Enterprise Server prior 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.9.17, 3.10.14, 3.11.12, 3.12.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | 3.9.0 ≤ v < 3.9.17, 3.10.0 ≤ v < 3.10.14, 3.11.0 ≤ v < 3.11.12, 3.12.0 ≤ v < 3.12.6, 3.13.0 | 3.9.17, 3.10.14, 3.11.12, 3.12.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.