CVE-2024-58375
Description
OpenTofu versions 1.8.0 through 1.8.2 do not properly restrict sensitive variables and locals when users have opted into static evaluation of module sources, versions, and backend configurations. As a result, values marked as sensitive may be exposed through these configuration elements instead of producing an error. This is fixed in OpenTofu 1.8.3, which adds explicit errors to prevent the use of sensitive values in these contexts.
How to fix
- github.com/opentofu/opentofu1.8.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github.com/opentofu/opentofuGo | 1.8.0 ≤ v < 1.8.3 | 1.8.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.