CVE-2024-5945

Medium

Description

The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.

SeverityMedium
CVSS6.4
Exploit probability—
ProductKubiq Wp Svg Images
PublishedJun 21, 2024
First seenJun 21, 2024

How to fix

Update
  • kubiq wp_svg_images4.3 or later

Affected products

ProductAffected versionsFixed in
kubiq wp_svg_imagesv < 4.34.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-5945 · Kubiq Wp Svg Images · Dark Radar