CVE-2024-7055
Description
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
How to fix
- ffmpeg ffmpeg4.3.8, 4.4.5, 5.1.6, 6.1.2, 7.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ffmpeg ffmpeg | v < 4.3.8, 4.4 ≤ v < 4.4.5, 5.0 ≤ v < 5.1.6, 6.0 ≤ v < 6.1.2, 7.0 ≤ v < 7.0.2 | 4.3.8, 4.4.5, 5.1.6, 6.1.2, 7.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.