CVE-2024-7884

High

Description

When a canister method is called via ic_cdk::call* , a new Future CallFuture is created and can be awaited by the caller to get the execution result. Internally, the state of the Future is tracked and stored in a struct called CallFutureState. A bug in the polling implementation of the CallFuture allows multiple references to be held for this internal state and not all references were dropped before the Future is resolved. Since we have unaccounted references held, a copy of the internal state ended up being persisted in the canister's heap and thus causing a memory leak. Impact Canisters built in Rust with ic_cdk and ic_cdk_timers are affected. If these canisters call a canister method, use timers or heartbeat, they will likely leak a small amount of memory on every such operation. In the worst case, this could lead to heap memory exhaustion triggered by an attacker. Motoko based canisters are not affected by the bug. PatchesThe patch has been backported to all minor versions between >= 0.8.0, <= 0.15.0. The patched versions available are 0.8.2, 0.9.3, 0.10.1, 0.11.6, 0.12.2, 0.13.5, 0.14.1, 0.15.1 and their previous versions have been yanked. WorkaroundsThere are no known workarounds at the moment. Developers are recommended to upgrade their canister as soon as possible to the latest available patched version of ic_cdk to avoid running out of Wasm heap memory. Upgrading the canisters (without updating `ic_cdk`) also frees the leaked memory but it's only a temporary solution.

SeverityHigh
CVSS7.5
Exploit probability—
ProductDfinity Canister Developer Kit For The Internet Computer
PublishedSep 5, 2024
First seenSep 5, 2024
Weakness typeCWE-401CWE-401

How to fix

Update
  • dfinity canister_developer_kit_for_the_internet_computer0.8.2, 0.9.3, 0.11.6, 0.12.2, 0.13.5 or later

Affected products

ProductAffected versionsFixed in
dfinity canister_developer_kit_for_the_internet_computer0.8.0 ≤ v < 0.8.2, 0.9.0 ≤ v < 0.9.3, 0.11.0 ≤ v < 0.11.6, 0.12.0 ≤ v < 0.12.2, 0.13.0 ≤ v < 0.13.5, 0.10.0, 0.14.0, 0.15.00.8.2, 0.9.3, 0.11.6, 0.12.2, 0.13.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.