CVE-2024-8263
Low
Description
An improper privilege management vulnerability allowed arbitrary workflows to be committed using an improperly scoped PAT through the use of nested tags. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.
SeverityLow
CVSS2.7
Exploit probability39. percentile0.4%
ProductGithub Enterprise Server
PublishedSep 23, 2024
First seenSep 23, 2024
Weakness typeCWE-269Improper privilege management
How to fix
Update
- github enterprise_server3.10.17, 3.11.15, 3.12.9, 3.13.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | 3.10.0 ≤ v < 3.10.17, 3.11.0 ≤ v < 3.11.15, 3.12.0 ≤ v < 3.12.9, 3.13.0 ≤ v < 3.13.4, 3.14.0 | 3.10.17, 3.11.15, 3.12.9, 3.13.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.