CVE-2024-8770
Description
A Cross-Site Scripting (XSS) vulnerability was identified in the repository transfer feature of GitHub Enterprise Server, which allows attackers to steal sensitive user information via social engineering. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.10.17, 3.11.15, 3.12.9, 3.13.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | 3.10.0 ≤ v < 3.10.17, 3.11.0 ≤ v < 3.11.15, 3.12.0 ≤ v < 3.12.9, 3.13.0 ≤ v < 3.13.4, 3.14.0 | 3.10.17, 3.11.15, 3.12.9, 3.13.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.