CVE-2024-9075

Low

Description

A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that "this functionality was removed in 0.29.0 already" and "we plan to re-add at later date with issue resolved".

SeverityLow
CVSS2.6
Exploit probability—
ProductStirlingpdf Stirling Pdf
PublishedSep 21, 2024
First seenSep 21, 2024

How to fix

Update
  • stirlingpdf stirling_pdf0.29.0 or later

Affected products

ProductAffected versionsFixed in
stirlingpdf stirling_pdfv < 0.29.00.29.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.