CVE-2024-9858
Description
There exists an insecure default user permission in Google Cloud Migrate to containers from version 1.1.0 to 1.2.2 Windows installs. A local "m2cuser" was greated with administrator privileges. This posed a security risk if the "analyze" or "generate" commands were interrupted or skipping the action to delete the local user “m2cuser”. We recommend upgrading to 1.2.3 or beyond
How to fix
- google migrate_to_containers1.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google migrate_to_containers | 1.1.0 ≤ v < 1.2.3 | 1.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.