CVE-2024-9946

High

Description

The Social Share, Social Login and Social Comments Plugin – Super Socializer plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 7.13.68. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, if they have access to the email and the user does not have an already-existing account for the service returning the token. An attacker cannot authenticate as an administrator by default, but these accounts are also at risk if authentication for administrators has explicitly been allowed via the social login. The vulnerability was partially patched in version 7.13.68.

SeverityHigh
CVSS8.1
Exploit probability—
ProductHeateor Super Socializer
PublishedNov 6, 2024
First seenNov 6, 2024

How to fix

Update
  • heateor super_socializer7.14 or later

Affected products

ProductAffected versionsFixed in
heateor super_socializerv < 7.147.14

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.