CVE-2025-0281

Medium

Description

A stored cross-site scripting (XSS) vulnerability exists in lunary-ai/lunary versions 1.6.7 and earlier. An attacker can inject malicious JavaScript into the SAML IdP XML metadata, which is used to generate the SAML login redirect URL. This URL is then set as the value of `window.location.href` without proper validation or sanitization. This vulnerability allows the attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions. The issue is fixed in version 1.7.10.

SeverityMedium
CVSS5.4
Exploit probability—
ProductLunary
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • lunary lunary1.7.10 or later

Affected products

ProductAffected versionsFixed in
lunary lunaryv < 1.7.101.7.10

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.