CVE-2025-0914

Low

Description

An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.

SeverityLow
CVSS3.8
Exploit probability—
ProductVelociraptor
PublishedFeb 27, 2025
First seenFeb 27, 2025
Weakness typeCWE-281CWE-281

How to fix

Update
  • Rapid7 Velociraptor0.73.4 or later

Affected products

ProductAffected versionsFixed in
Rapid7 Velociraptorv < 0.73.40.73.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.