CVE-2025-1040

High

Description

AutoGPT versions 0.3.4 and earlier are vulnerable to a Server-Side Template Injection (SSTI) that could lead to Remote Code Execution (RCE). The vulnerability arises from the improper handling of user-supplied format strings in the `AgentOutputBlock` implementation, where malicious input is passed to the Jinja2 templating engine without adequate security measures. Attackers can exploit this flaw to execute arbitrary commands on the host system. The issue is fixed in version 0.4.0.

SeverityHigh
CVSS8.8
Exploit probability78. percentile1.7%
ProductAgpt Autogpt Platform
PublishedMar 20, 2025
First seenMar 20, 2025
Weakness typeCWE-1336CWE-1336

How to fix

Update
  • agpt autogpt_platform0.4.0 or later

Affected products

ProductAffected versionsFixed in
agpt autogpt_platformv < 0.4.00.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.