CVE-2025-1215

Low

Description

A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.

SeverityLow
CVSS2.8
Exploit probability—
ProductVim
PublishedFeb 12, 2025
First seenFeb 12, 2025

How to fix

Affected products

ProductAffected versionsFixed in
vim vimv < 9.1.10979.1.1097
netapp bootstrap_osNo range specified—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.