CVE-2025-1293
High
Description
Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.
SeverityHigh
CVSS8.2
Exploit probability—
Product
Hashicorp Hermes
PublishedFeb 20, 2025
First seenFeb 20, 2025
Weakness typeCWE-1390CWE-1390
How to fix
Update
- hashicorp hermes0.5.0 or later
- github.com/hashicorp-forge/hermes0.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp hermes | v < 0.5.0 | 0.5.0 |
| github.com/hashicorp-forge/hermesGo | v < 0.5.0 | 0.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.