CVE-2025-12943

High

Description

Improper certificate validation in firmware update logic in NETGEAR RAX30 (Nighthawk AX5 5-Stream AX2400 WiFi 6 Router) and RAXE300 (Nighthawk AXE7800 Tri-Band WiFi 6E Router) allows attackers with the ability to intercept and tamper traffic destined to the device to execute arbitrary commands on the device. Devices with automatic updates enabled may already have this patch applied. If not, please check the firmware version and update to the latest. Fixed in: RAX30 firmware 1.0.14.108 or later. RAXE300 firmware 1.0.9.82 or later

SeverityHigh
CVSS7.5
Exploit probability—
ProductNetgear Rax30 Firmware
PublishedNov 11, 2025
First seenNov 11, 2025
Weakness typeCWE-295CWE-295

How to fix

Update
  • netgear rax30_firmware1.0.14.108 or later
  • netgear raxe300_firmware1.0.9.82 or later

Affected products

ProductAffected versionsFixed in
netgear rax30_firmwarev < 1.0.14.1081.0.14.108
netgear raxe300_firmwarev < 1.0.9.821.0.9.82

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.