CVE-2025-12944

High

Description

Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in:  DGN2200v4 firmware 1.0.0.132 or later

SeverityHigh
CVSS8.8
Exploit probability19. percentile0.3%
ProductNetgear Dgn2200 Firmware
PublishedNov 11, 2025
First seenNov 11, 2025

How to fix

Update
  • netgear dgn2200_firmware1.0.0.132 or later

Affected products

ProductAffected versionsFixed in
netgear dgn2200_firmwarev < 1.0.0.1321.0.0.132

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.