CVE-2025-13146

Medium

Description

The The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.0.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The vulnerability was partially patched in version 5.0.4.

SeverityMedium
CVSS6.5
Exploit probability—
ProductDTX – Dynamic Text Extension for Contact Form 7
PublishedJul 22, 2026
First seenJul 22, 2026

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
sevenspark DTX – Dynamic Text Extension for Contact Form 7v ≤ 5.0.7—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.