CVE-2025-13465
Description
The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. The issue is patched from 4.17.23 to 4.18.0 depending on the package: lodash, lodash-es, and lodash-amd in 4.17.23, and the standalone lodash.unset and lodash.omit packages in 4.18.0.
How to fix
- lodash lodash4.17.23 or later
- lodash4.17.23 or later
- lodash.unset4.18.0 or later
- lodash-es4.17.23 or later
- lodash-amd4.17.23 or later
- lodash.omit4.18.0 or later
- access.redhat.com/errata/RHSA-2026:33371
- access.redhat.com/errata/RHSA-2026:3958
- access.redhat.com/errata/RHSA-2026:1845
- access.redhat.com/errata/RHSA-2026:18480
- access.redhat.com/errata/RHSA-2026:24331
- access.redhat.com/errata/RHSA-2026:18868
- access.redhat.com/errata/RHSA-2026:4782
- access.redhat.com/errata/RHSA-2026:25089
- access.redhat.com/errata/RHSA-2026:2818
- access.redhat.com/errata/RHSA-2026:2438
- access.redhat.com/errata/RHSA-2026:2462
- access.redhat.com/errata/RHSA-2026:2469
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| lodash lodash | 4.0.0 ≤ v < 4.17.23 | 4.17.23 |
| lodashnpm | 4.0.0 ≤ v < 4.17.23, 4.0.0 ≤ v ≤ 4.17.22 | 4.17.23 |
| lodash.unsetnpm | 4.0.0 ≤ v ≤ 4.5.2, 4.0.0 ≤ v < 4.18.0 | 4.18.0 |
| lodash-esnpm | 4.0.0 ≤ v < 4.17.23 | 4.17.23 |
| lodash-amdnpm | 4.0.0 ≤ v < 4.17.23, 4.0.0 ≤ v ≤ 4.17.22 | 4.17.23 |
| lodash.omitnpm | 4.0.0 ≤ v < 4.18.0 | 4.18.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.