CVE-2025-14280

Medium

Description

The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.

SeverityMedium
CVSS5.3
Exploit probability—
ProductPixelYourSite – Your smart PIXEL (TAG) & API Manager
PublishedDec 29, 2025
First seenDec 29, 2025

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
pixelyoursite PixelYourSite – Your smart PIXEL (TAG) & API Managerv ≤ 11.1.5—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.