CVE-2025-14692
Description
A flaw has been found in Mayan EDMS up to 4.10.1. The impacted element is an unknown function of the file /authentication/. This manipulation causes open redirect. It is possible to initiate the attack remotely. The exploit has been published and may be used. Upgrading to version 4.10.2 is sufficient to resolve this issue. The affected component should be upgraded. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
How to fix
- mayan-edms mayan_edms4.10.2 or later
- mayan-edms4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mayan-edms mayan_edms | v < 4.10.2 | 4.10.2 |
| mayan-edmsPyPI | 4.10.0 ≤ v < 4.10.2, 4.9.0 ≤ v < 4.9.7, 4.8.0 ≤ v < 4.8.10, 4.7.0 ≤ v < 4.7.8, v < 4.6.12, v < 4.10.2 | 4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.