CVE-2025-15033
Medium
Description
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
SeverityMedium
CVSS6.5
Exploit probability—
Product
WooCommerce
PublishedDec 22, 2025
First seenDec 22, 2025
How to fix
Update
- Automattic WooCommerce8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4, 8.6.3, 8.7.2, 8.8.6, 8.9.4, 9.0.3, 9.1.5, 9.2.4, 9.3.5, 9.4.4, 9.5.3, 9.6.3, 9.7.2, 9.8.6, 9.9.6, 10.0.5, 10.1.3, 10.2.3, 10.3.7, 10.4.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Automattic WooCommerce | 8.1.0 ≤ v < 8.1.3, 8.2.0 ≤ v < 8.2.4, 8.3.0 ≤ v < 8.3.3, 8.4.0 ≤ v < 8.4.2, 8.5.0 ≤ v < 8.5.4, 8.6.0 ≤ v < 8.6.3, 8.7.0 ≤ v < 8.7.2, 8.8.0 ≤ v < 8.8.6, 8.9.0 ≤ v < 8.9.4, 9.0.0 ≤ v < 9.0.3, 9.1.0 ≤ v < 9.1.5, 9.2.0 ≤ v < 9.2.4, 9.3.0 ≤ v < 9.3.5, 9.4.0 ≤ v < 9.4.4, 9.5.0 ≤ v < 9.5.3, 9.6.0 ≤ v < 9.6.3, 9.7.0 ≤ v < 9.7.2, 9.8.0 ≤ v < 9.8.6, 9.9.0 ≤ v < 9.9.6, 10.0.0 ≤ v < 10.0.5, 10.1.0 ≤ v < 10.1.3, 10.2.0 ≤ v < 10.2.3, 10.3.0 ≤ v < 10.3.7, 10.4.0 ≤ v < 10.4.3 | 8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4, 8.6.3, 8.7.2, 8.8.6, 8.9.4, 9.0.3, 9.1.5, 9.2.4, 9.3.5, 9.4.4, 9.5.3, 9.6.3, 9.7.2, 9.8.6, 9.9.6, 10.0.5, 10.1.3, 10.2.3, 10.3.7, 10.4.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.