CVE-2025-15444

Critical

Description

Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277  https://www.cve.org/CVERecord?id=CVE-2025-69277 . The libsodium vulnerability states: In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. 0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.

SeverityCritical
CVSS9.8
Exploit probability—
ProductIamb Crypt\
PublishedJan 6, 2026
First seenJan 6, 2026
Weakness typeCWE-1395CWE-1395

How to fix

Update
  • iamb crypt\0.000042 or later

Affected products

ProductAffected versionsFixed in
iamb crypt\\ ≤ v < 0.0000420.000042

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.