CVE-2025-15587
Description
Tinycontrol devices such as tcPDU and LAN Controllers LK3.5, LK3.9 and LK4 allow a low privileged user to read an administrator's password by directly accessing a specific resource inaccessible via a graphical interface. This issue has been fixed in firmware versions: 1.36 (for tcPDU), 1.67 (for LK3.5 - hardware versions: 3.5, 3.6, 3.7 and 3.8), 1.75 (for LK3.9 - hardware version 3.9) and 1.38 (for LK4 - hardware version 4.0).
How to fix
- tinycontrol LK3.91.75 or later
- tinycontrol Lan Kontroler v3.51.67 or later
- tinycontrol LK41.38 or later
- tinycontrol tcPDU1.36 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| tinycontrol LK3.9 | v < 1.75 | 1.75 |
| tinycontrol Lan Kontroler v3.5 | v < 1.67 | 1.67 |
| tinycontrol LK4 | v < 1.38 | 1.38 |
| tinycontrol tcPDU | v < 1.36 | 1.36 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.