CVE-2025-21612
High
Description
TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Prior to 2.7.2, TabberTransclude.php doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This vulnerability is fixed in 2.7.2.
SeverityHigh
CVSS8.6
Exploit probability—
ProductStarcitizentools/tabber-neue
PublishedJan 6, 2025
First seenJan 6, 2025
Weakness typeCWE-79Cross-site scripting (XSS)CWE-80CWE-80
How to fix
Update
- starcitizentools/tabber-neue2.7.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| starcitizentools/tabber-neuePackagist | 1.9.1 ≤ v < 2.7.2 | 2.7.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.