CVE-2025-21614
Description
go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.
How to fix
- go-git_project go-git5.13.0 or later
- github.com/go-git/go-git/v55.13.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| go-git_project go-git | v < 5.13.0 | 5.13.0 |
| gopkg.in/src-d/go-git.v4Go | 4.0.0 ≤ v ≤ 4.13.1, 4.0.0 ≤ v | — |
| github.com/go-git/go-git/v5Go | v < 5.13.0 | 5.13.0 |
| github.com/go-git/go-gitGo | 4.0.0 ≤ v ≤ 4.13.1 | — |
| github.com/go-git/go-git/v4Go | 4.0.0 ≤ v | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.