CVE-2025-2177

High

Description

A vulnerability classified as critical was found in libzvbi up to 0.2.43. This vulnerability affects the function vbi_search_new of the file src/search.c. The manipulation of the argument pat_len leads to integer overflow. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

SeverityHigh
CVSS7.3
Exploit probability—
ProductZapping-vbi Zvbi
PublishedMar 11, 2025
First seenMar 11, 2025

How to fix

Affected products

ProductAffected versionsFixed in
zapping-vbi zvbiv < 0.2.440.2.44

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-2177 · Zapping-vbi Zvbi · Dark Radar