CVE-2025-22166
Description
This High severity DoS (Denial of Service) vulnerability was introduced in version 2.0 of Confluence Data Center. This DoS (Denial of Service) vulnerability, with a CVSS Score of 8.3, allows an attacker to cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a host connected to a network. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.25 Confluence Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.7 Confluence Data Center and Server 10.0: Upgrade to a release greater than or equal to 10.0.2 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.
How to fix
- atlassian confluence_data_center8.5.25, 9.2.7, 10.0.2 or later
- atlassian confluence_server8.5.25, 9.2.7, 10.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| atlassian confluence_data_center | 8.5.0 ≤ v < 8.5.25, 9.2.0 ≤ v < 9.2.7, 10.0.0 ≤ v < 10.0.2 | 8.5.25, 9.2.7, 10.0.2 |
| atlassian confluence_server | 8.5.0 ≤ v < 8.5.25, 9.2.0 ≤ v < 9.2.7, 10.0.0 ≤ v < 10.0.2 | 8.5.25, 9.2.7, 10.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.