CVE-2025-22395

High

Description

Dell Update Package Framework, versions prior to 22.01.02, contain(s) a Local Privilege Escalation Vulnerability. A local low privileged attacker could potentially exploit this vulnerability, leading to the execution of arbitrary remote scripts on the server. Exploitation may lead to a denial of service by an attacker.

SeverityHigh
CVSS8.2
Exploit probability—
ProductDell Update Package Framework
PublishedJan 7, 2025
First seenJan 7, 2025
Weakness typeCWE-280CWE-280

How to fix

Affected products

ProductAffected versionsFixed in
dell update_package_frameworkv < 22.01.0222.01.02

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.