CVE-2025-23015

High

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Cassandra
PublishedFeb 4, 2025
First seenFeb 4, 2025
Weakness typeCWE-267CWE-267

How to fix

Update
  • apache cassandra3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3 or later
  • org.apache.cassandra:cassandra-all5.0.3, 4.1.8, 4.0.16, 3.11.18, 3.0.31 or later

Affected products

ProductAffected versionsFixed in
apache cassandra3.0.0 ≤ v < 3.0.31, 3.1 ≤ v < 3.11.18, 4.0.0 ≤ v < 4.0.16, 4.1.0 ≤ v < 4.1.8, 5.0.0 ≤ v < 5.0.33.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3
org.apache.cassandra:cassandra-allMaven5.0-alpha1 ≤ v < 5.0.3, 4.1-alpha1 ≤ v < 4.1.8, 4.0-alpha1 ≤ v < 4.0.16, 3.1 ≤ v < 3.11.18, v < 3.0.315.0.3, 4.1.8, 4.0.16, 3.11.18, 3.0.31

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.