CVE-2025-24010
Medium
Description
Vite is a frontend tooling framework for javascript. Vite allowed any websites to send any requests to the development server and read the response due to default CORS settings and lack of validation on the Origin header for WebSocket connections. This vulnerability is fixed in 6.0.9, 5.4.12, and 4.5.6.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Vite
PublishedJan 20, 2025
First seenJan 20, 2025
Weakness typeCWE-346CWE-346CWE-350CWE-350CWE-1385CWE-1385
How to fix
Update
- vitejs vite4.5.5, 5.4.12, 6.0.9 or later
- vite6.0.9, 5.4.12, 4.5.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vitejs vite | v < 4.5.5, 5.0.0 ≤ v < 5.4.12, 6.0.0 ≤ v < 6.0.9 | 4.5.5, 5.4.12, 6.0.9 |
| vitenpm | 6.0.0 ≤ v < 6.0.9, 5.0.0 ≤ v < 5.4.12, v < 4.5.6 | 6.0.9, 5.4.12, 4.5.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.